Threat Alerts / Oct 13, 2021

Each vulnerability will have a severity rating of Low, Medium, High, or Critical. Responsible disclosure and reporting of vulnerabilities is an integral part of keeping the WordPress community safe.

 

WordPress Core Vulnerabilities

The latest version of WordPress core is 5.8.1 was released as a security and maintenance release. As a best practice, always be sure to run the latest version of WordPress core!

WordPress Plugin Vulnerabilities

1. Easy PayPal Buy Now Button

Plugin: Easy PayPal Buy Now Button Vulnerability: CSRF to Stored Cross-Site Scripting Patched in Version: 1.7.3 Severity Score: High

The vulnerability is patched, so you should update to version 1.7.3.

2. Events Made Easy

Plugin: Events Made Easy Vulnerability: Admin+ Stored Cross-Site Scripting Patched in Version: 2.2.24 Severity Score: Low

The vulnerability is patched, so you should update to version 2.2.24.

3. BP Better Messages

Plugin: BP Better Messages Vulnerability: Reflected Cross-Site Scripting Patched in Version: 1.9.9.41 Severity Score: High

The vulnerability is patched, so you should update to version 1.9.9.41.

Plugin: BP Better Messages Vulnerability: Multiple CSRF Patched in Version: 1.9.9.41 Severity Score: Medium

The vulnerability is patched, so you should update to version 1.9.9.41.

4. Themify Builder

Plugin: Themify Builder Vulnerability: Reflected Cross-Site Scripting Patched in Version: 5.3.2 Severity Score: High

The vulnerability is patched, so you should update to version 5.3.2.

5. Far Future Expiry Header

Plugin: Far Future Expiry Header Vulnerability: Plugin’s Settings Update via CSRF Patched in Version: 1.5 Severity Score: Medium

The vulnerability is patched, so you should update to version 1.5.

6. Image Source Control

Plugin: Image Source Control Vulnerability: Contributor+ Arbitrary Post Meta Value Change Patched in Version: 2.3.1 Severity Score: Medium

The vulnerability is patched, so you should update to version 2.3.1.

7. Logo Slider and Showcase

Plugin: Logo Slider and Showcase Vulnerability: Editor Plugin’s Settings Update Patched in Version: 1.3.37 Severity Score: Low

The vulnerability is patched, so you should update to version 1.3.37.

8. Cardinity Payment Gateway for WooCommerce

Plugin: Cardinity Payment Gateway for WooCommerce Vulnerability: Reflected Cross-Site Scripting Patched in Version: 3.0.7 Severity Score: High

The vulnerability is patched, so you should update to version 3.0.7.

9. MP3 Audio Player for Music, Radio & Podcast by Sonaar

Plugin: MP3 Audio Player for Music, Radio & Podcast by Sonaar Vulnerability: Multiple Admin+ Cross Site Scripting Patched in Version: 2.4.2 Severity Score: Low

The vulnerability is patched, so you should update to version 2.4.2.

10. Paypal Donation

Plugin: Paypal Donation Vulnerability: CSRF to Arbitrary Post Deletion Patched in Version: 1.3.1 Severity Score: Medium

The vulnerability is patched, so you should update to version 1.3.1.

Plugin: Paypal Donation Vulnerability: CSRF to Stored Cross-Site Scripting Patched in Version: 1.3.1 Severity Score: High

The vulnerability is patched, so you should update to version 1.3.1.

11. Coming Soon, Under Construction & Maintenance Mode By Dazzler

Plugin: Coming Soon, Under Construction & Maintenance Mode By Dazzler Vulnerability: Admin+ Stored Cross-Site Scripting Patched in Version: 1.6.7 Severity Score: Low

The vulnerability is patched, so you should update to version 1.6.7.

12. Translate WordPress – Google Language Translator 

Plugin: Translate WordPress – Google Language Translator Vulnerability: Admin+ Stored Cross-Site Scripting Patched in Version: 6.0.12 Severity Score: Low

The vulnerability is patched, so you should update to version 6.0.12.

13. Booking.com Product Helper

Plugin: Booking.com Product Helper Vulnerability: Admin+ Stored Cross-Site Scripting Patched in Version: No known fix – plugin closed Severity Score: Low

This vulnerability has NOT been patched. This plugin has been closed as of August 18, 2021. Uninstall and delete.

14. Booking.com Banner Creator

Plugin: Booking.com Banner Creator Vulnerability: Admin+ Stored Cross-Site Scripting Patched in Version: No known fix – plugin closed Severity Score: Low

This vulnerability has NOT been patched. This plugin has been closed as of August 18, 2021. Uninstall and delete.

15. Simple Download Monitor

Plugin: Simple Download Monitor Vulnerability: Unauthorised Log Reset Patched in Version: 3.9.6 Severity Score: Medium

The vulnerability is patched, so you should update to version 3.9.6.

Plugin: Simple Download Monitor Vulnerability: Arbitrary Thumbnails Removal Patched in Version: 3.9.6 Severity Score: Medium

The vulnerability is patched, so you should update to version 3.9.6.

Plugin: Simple Download Monitor Vulnerability: Unauthenticated Log Access Patched in Version: 3.9.6 Severity Score: Medium

The vulnerability is patched, so you should update to version 3.9.6.

Plugin: Simple Download Monitor Vulnerability: Reflected Cross-Site Scripting Patched in Version: 3.9.5 Severity Score: High

The vulnerability is patched, so you should update to version 3.9.5.

Plugin: Simple Download Monitor Vulnerability: Contributor+ Stored Cross-Site Scripting via File Thumbnail Patched in Version: 3.9.5 Severity Score: High

The vulnerability is patched, so you should update to version 3.9.5.

16. Two Way Chat

Plugin: Two Way Chat Vulnerability: Multiple CSRF Patched in Version: 3.1.5 Severity Score: Medium

The vulnerability is patched, so you should update to version 3.1.5.

Plugin: Two Way Chat Vulnerability: Admin+ Local File Inclusion Patched in Version: 3.1.5 Severity Score: Low

The vulnerability is patched, so you should update to version 3.1.5.

17. WP-Recall

Plugin: WP-Recall Vulnerability: Reflected Cross-Site Scripting Patched in Version: 16.24.48 Severity Score: High

The vulnerability is patched, so you should update to version 16.24.48.

18. JobSearch WP Job Board

Plugin: JobSearch WP Job Board Vulnerability: Subscriber+ Arbitrary Blog Options Update Patched in Version: 1.8.2 Severity Score: High

The vulnerability is patched, so you should update to version 1.8.2.

Plugin: JobSearch WP Job Board Vulnerability: Unauthenticated Plugin’s Settings Update Patched in Version: 1.8.2 Severity Score: Medium

The vulnerability is patched, so you should update to version 1.8.2.

Plugin: JobSearch WP Job Board Vulnerability: Subscriber+ Add/Update Schedule Calls Patched in Version: 1.8.2 Severity Score: Medium

The vulnerability is patched, so you should update to version 1.8.2.

19. TheCartPress eCommerce Shopping Cart

Plugin: TheCartPress eCommerce Shopping Cart Vulnerability: CSRF to Stored Cross-Site Scripting Patched in Version: No known fix – plugin closed Severity Score: High

This vulnerability has NOT been patched. This plugin has been closed as of October 5, 2021. Uninstall and delete.

20. MStore API

Plugin: MStore API Vulnerability: Unauthenticated PHP File Upload Patched in Version: No known fix – plugin closed Severity Score: Critical

This vulnerability has NOT been patched. This plugin has been closed as of October 5, 2021. Uninstall and delete.

21. Media File Renamer – Auto & Manual Rename

Plugin: Media File Renamer – Auto & Manual Rename Vulnerability: Media Title/Filename/Locking State Update via CSRF Patched in Version: 5.2.7 Severity Score: Medium

The vulnerability is patched, so you should update to version 5.2.7.

22. Batch Cat

Plugin: Batch Cat Vulnerability: Subscriber+ Arbitrary Categories Add/Set/Delete to Posts Patched in Version: No known fix – plugin closed Severity Score: Medium

This vulnerability has NOT been patched. This plugin has been closed as of September 24, 2021. Uninstall and delete.

23. qTranslate X

Plugin: qTranslate X Vulnerability: Multiple Admin+ Stored Cross-Site Scripting Patched in Version: No known fix – plugin closed Severity Score: Low

This vulnerability has NOT been patched. This plugin has been closed as of August 31, 2021. Uninstall and delete.

24. World Travel Information 

Plugin: World Travel Information Vulnerability: Reflected Cross-Site Scripting Patched in Version: No known fix – plugin closed Severity Score: High

This vulnerability has NOT been patched. This plugin has been closed as of September 23, 2021. Uninstall and delete.

25. WP Survey Plus

Plugin: WP Survey Plus Vulnerability: Subscriber+ AJAX Calls Patched in Version: No known fix – plugin closed Severity Score: High

This vulnerability has NOT been patched. This plugin has been closed as of September 30, 2021. Uninstall and delete.

26. WP Sitemap Page

Plugin: WP Sitemap Page Vulnerability: Admin+ Stored Cross Site Scripting Patched in Version: No known fix Severity Score: Low

This vulnerability has NOT been patched. Uninstall and delete the plugin until a patch is released.

27. WP Bannerize 2.0.0

Plugin: WP Bannerize 2.0.0 Vulnerability: Authenticated SQL Injection Patched in Version: No known fix – plugin closed Severity Score: High

This vulnerability has NOT been patched. This plugin has been closed as of July 19, 2021. Uninstall and delete.

28. Genie WP Favicon

Plugin: Genie WP Favicon Vulnerability: Arbitrary Favicon Change via CSRF Patched in Version: No known fix – plugin closed Severity Score: Medium

This vulnerability has NOT been patched. This plugin has been closed as of August 27, 2021. Uninstall and delete.

29. Phoenix Media Rename 

Plugin: Phoenix Media Rename Vulnerability: Author Arbitrary Media File Renaming Patched in Version: 3.4.4 Severity Score: Medium

The vulnerability is patched, so you should update to version 3.4.4.

30. Visitor Traffic Real Time Statistics

Plugin: Visitor Traffic Real Time Statistics Vulnerability: Subscriber+ SQL Injection Patched in Version: 3.9 Severity Score: High

The vulnerability is patched, so you should update to version 3.9.

31. AddToAny Share Buttons

Plugin: AddToAny Share Buttons Vulnerability: Admin+ Stored Cross-Site Scripting Patched in Version: 1.7.48 Severity Score: Low

The vulnerability is patched, so you should update to version 1.7.48.

32. Formidable Form Builder

Plugin: Formidable Form Builder Vulnerability: Admin+ Stored Cross-Site Scripting Patched in Version: 5.0.07 Severity Score: Low

The vulnerability is patched, so you should update to version 5.0.07.

33. BulletProof Security

Plugin: BulletProof Security Vulnerability: Sensitive Information Disclosure Patched in Version: 5.2 Severity Score: Medium

The vulnerability is patched, so you should update to version 5.2.

34. WP All Export

Plugin: WP All Export Vulnerability: Admin+ Stored Cross-Site Scripting Patched in Version: 1.3.1 Severity Score: Low

The vulnerability is patched, so you should update to version 1.3.1.

35. Redirect 404 Error Page to Homepage or Custom Page with Logs

Plugin: Redirect 404 Error Page to Homepage or Custom Page with Logs Vulnerability: Log Deletion via CSRF Patched in Version: 1.7.9 Severity Score: Medium

The vulnerability is patched, so you should update to version 1.7.9.

36. Access Demo Importer

Plugin: Access Demo Importer Vulnerability: Subscriber+ Arbitrary File Upload Patched in Version: 1.0.7 Severity Score: High

The vulnerability is patched, so you should update to version 1.0.7.

37. Download Monitor

Plugin: Download Monitor Vulnerability: Unauthenticated Downloading of Logs Patched in Version: 1.9.7 Severity Score: Medium

The vulnerability is patched, so you should update to version 1.9.7.

Plugin: Download Monitor Vulnerability: Reflected Cross-Site Scripting (XSS) Patched in Version: 1.7.1 Severity Score: Medium

The vulnerability is patched, so you should update to version 1.7.1.

Plugin: Download Monitor Vulnerability: Authenticated Directory Listing Patched in Version: 1.6.4 Severity Score: Medium

The vulnerability is patched, so you should update to version 1.6.4.

Plugin: Download Monitor Vulnerability: Multiple Reflected Cross-Site Scripting Patched in Version: 3.3.6.2 Severity Score: Medium

The vulnerability is patched, so you should update to version 3.3.6.2.

38. Unlimited PopUps

Plugin: Unlimited PopUps Vulnerability: Author+ SQL Injection Patched in Version: No known fix – plugin closed Severity Score: High

This vulnerability has NOT been patched. This plugin has been closed as of June 22, 2021. Uninstall and delete.

39. Schreikasten

Plugin: Schreikasten Vulnerability: Author+ SQL Injections Patched in Version: No known fix – plugin closed Severity Score: High

This vulnerability has NOT been patched. This plugin has been closed as of June 21, 2021. Uninstall and delete.

40. Post Content XMLRPC

Plugin: Post Content XMLRPC Vulnerability: Author+ SQL Injections Patched in Version: No known fix – plugin closed Severity Score: High

This vulnerability has NOT been patched. This plugin has been closed as of June 21, 2021. Uninstall and delete.

41. Wow Forms

Plugin: Wow Forms Vulnerability: Author+ SQL Injections Patched in Version: No known fix – plugin closed Severity Score: High

This vulnerability has NOT been patched. This plugin has been closed as of June 18, 2021. Uninstall and delete..

42. Auto-Hyperlink

Plugin: G Auto-Hyperlink Vulnerability: Author+ SQL Injection Patched in Version: No known fix – plugin closed Severity Score: Medium

This vulnerability has NOT been patched. This plugin has been closed as of June 18, 2021. Uninstall and delete.

43. Chameleon CSS

Plugin: Chameleon CSS Vulnerability: Subscriber+ SQL Injection Patched in Version: No known fix – plugin closed Severity Score: Critical

This vulnerability has NOT been patched. This plugin has been closed as of June 18, 2021. Uninstall and delete.

44. SpiderCatalog

Plugin: SpiderCatalog Vulnerability: Author+ SQL Injection Patched in Version: No known fix – plugin closed Severity Score: Medium

This vulnerability has NOT been patched. This plugin has been closed as of June 18, 2021. Uninstall and delete.

45. Support Board 

Plugin: Support Board Vulnerability: Agent+ Stored Cross-Site Scripting Patched in Version: 3.3.5 Severity Score: Medium

The vulnerability is patched, so you should update to version 3.3.5.

46. Age Gate

Plugin: Age Gate Vulnerability: Authenticated Stored Cross-Site Scripting Patched in Version: 2.16.4 Severity Score: Medium

The vulnerability is patched, so you should update to version 2.16.4.

47. Inline Related Posts

Plugin: Inline Related Posts Vulnerability: Admin+ Cross-Site Scripting Patched in Version: 3.0.5 Severity Score: Low

The vulnerability is patched, so you should update to version 3.0.5.

 

If you are under WordPress Managed Maintenance plan - there is nothing to worry about as we've taken the necessary steps to protect your sites. Yay! 

The information for this blog post was taken from iThemes Vulnerability Roundup

If you're not under our maintenance plan... well, what are you waiting for? Sign-up today!